欢迎回家
我们一直在改变

JavaScript 版本 JS版本

JavaScript 版本

JavaScript 由 Brendan Eich 于 1995 年发明,并于 1997 年成为 ECMA 标准。

ECMAScript 是该语言的官方名称。

从 2015 年起,ECMAScript 按年命名(ECMAScript 2015)。

ECMAScript 版本

版本官方名称描述
1ECMAScript 1 (1997)第一版。
2ECMAScript 2 (1998)只改变编辑方式。
3ECMAScript 3 (1999)添加了正则表达式。添加了 try/catch。
4ECMAScript 4从未发布过。
5ECMAScript 5 (2009)阅读更多:JS ES5添加了“严格模式”。添加了 JSON 支持。添加了 String.trim()。添加了 Array.isArray()。添加了数组迭代方法。
5.1ECMAScript 5.1 (2011)编辑改变。
6ECMAScript 2015阅读更多:JS ES6添加了 let 和 const添加了默认参数值添加了 Array.find()添加了 Array.findIndex()
7ECMAScript 2016添加了指数运算符(**)。添加了 Array.prototype.includes。
8ECMAScript 2017添加了字符串填充。添加了新的 Object 属性。添加了异步功能。添加了共享内存。
9ECMAScript 2018添加了 rest / spread 属性。添加了异步迭代。添加了 Promise.finally()。增加 RegExp。

ECMAScript 通常缩写为 ES。

浏览器支持

所有浏览器都完全支持 ECMAScript 3。

所有现代浏览器都完全支持 ECMAScript 5。

对 ES5 的浏览器支持(2009)

浏览器版本起始日期
Chrome232012 年 9 月
Firefox212013 年 4 月
IE9*2011 年 3 月
IE / Edge102012 年 9 月
Safari62012 年 7 月
Opera152013 年 7 月

* Internet Explorer 9 不支持 ECMAScript 5 “use strict”。

对 ES6 的浏览器支持(ECMAScript 2015)

浏览器版本日期
Chrome582017 年 4 月
Firefox542017 年 6 月
Edge142016 年 8 月
Safari102016 年 9 月
Opera552017 年 8 月

Internet Explorer 不支持 ECMAScript 2015。

对 ES7 的浏览器支持(ECMAScript 2016)

浏览器版本日期
Chrome682018 年 5 月
Opera472018 年 7 月

JavaScript / ECMAScript

JavaScript 是为 Netscape 开发的。 Netscape 2 是第一个运行 JavaScript 的浏览器。

在 Netscape 之后,Mozilla 基金会继续为 Firefox 浏览器开发 JavaScript。

最新的 JavaScript 版本是 1.8.5。 (与 ECMAScript 5 相同)。

ECMAScript 由 ECMA International 在组织采用 JavaScript 之后开发的。

第一版 ECMAScript 于 1997 年发布。

此列表比较了不同产品的版本号:

年份JavaScriptECMA浏览器
19961.0Netscape 2
1997ECMAScript 1IE 4
19981.3Netscape 4
1999ECMAScript 2IE 5
2000ECMAScript 3IE 5.5
20001.5Netscape 6
20001.5Firefox 1
2011ECMAScript 5IE 9(除了 “use strict”)
20111.8.5Firefox 4(除了 parseInt 中的前导零)
2012IE 10
2012Chrome 23
2012Safari 6
2013Firefox 21
2013Opera 15
2015ECMAScript 2015在所有浏览器中部分支持

IE 4 是第一个支持 ECMAScript 1(1997)的浏览器。

IE 5 是第一个支持 ECMAScript 2(1999)的浏览器。

IE 5.5 是第一个支持 ECMAScript 3(2000)的浏览器。

IE 9 * 是第一个支持 ECMAScript 5(2011)的浏览器。

Internet Explorer 9 不支持 ECMAScript 5“use strict”。

Chrome 23、IE 10 和Safari 6 是第一批完全支持 ECMAScript 5 的浏览器。

原文链接: https://www.w3school.com.cn/js/js_versions.asp

赞(0)
未经允许不得转载:91coding » JavaScript 版本
分享到: 更多 (0)

评论 抢沙发

评论前必须登录!

立即登录   注册

91CODING 小白轻松上手,大牛稳健进步

关于我们免责声明